Ubuntu 5735-1: Sysstat vulnerability

Ubuntu 5735-1: Sysstat vulnerability

==========================================================================
Ubuntu Security Notice USN-5735-1
November 22, 2022

sysstat vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

Sysstat could be made to crash or run programs as your login if it
processed specially crafted input.

Software Description:
- sysstat: system performance tools for Linux

Details:

It was discovered that Sysstat did not properly check bounds
when perfoming certain arithmetic operations on 32 bit systems.
An attacker could possibly use this issue to cause a crash or
arbitrary code execution.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
 sysstat 11.2.0-1ubuntu0.3+esm1

In general, a standard system update will make all the necessary changes.

References:
 https://ubuntu.com/security/notices/USN-5735-1
 CVE-2022-39377

https://linuxsecurity.com/advisories/ubuntu/ubuntu-5735-1-sysstat-vulnerability-18-06-56